Image 01
profile-image

patkoscsaba

Patkos Csaba Timisoara, Romania
Plasma 4 Widgets
Animals
Bridges
GTK2 Themes
Plasma Themes
Dropbox ServiceMenu

Dolphin Service Menus 124 comments

Score 85.0%
Jan 29 2012
This is great, working superbly, it will make my life a lot easier. Excellent method for quickly sharing files. Good job. - May 16 2012
Simple NVidia Info

Plasma 4 Widgets 35 comments

Score 83.6%
May 08 2011
Auto-looping with timer detached:
- this is highly unlikely. As far as I understand the timer's working, if it crashes the plasmoid will stop refreshing. Since the timer is the only element that 'generates a loop' periodically, I can see no way to re-run the code outside of the timer.

About contacting plasma devs... Unless I will find out about other people reporting this bug also, I will not take further actions. This may very well be an isolated situation in your case. Plus, if you like this plasmoid, version 2, build on Ruby instead of Python is out, so I recommend using that.

I decided not to remove this one for those people which can not install ruby-plasma-engine for various reasons and prefer the python version.

Unless there is a reproducible (many times in many places) severe bug, I am not planning to further update this version of the plasmoid. - Jan 03 2012
Can you give more details (I do not really understand the dump for the link you provided). The plasmoid is so simple that it only does a few grep and sed, nothing else. The only looping code is called by a QT::Timer class. If that is causing the problem, than QT Timer is the problem, or the python bindings...

self.timer = QtCore.QTimer();
self.timer.setInterval(10000);
self.timer.start(10000);
QtCore.QObject.connect(self.timer, QtCore.SIGNAL("timeout()"), self._updatelabel) - Jan 03 2012
I'm happy I solved your problem. Sorry for the delay, I was very busy in these last months. - May 08 2011
Your solution is like mine, it is working for you but may not work for others. You base your logic on the fact that the GPUCoreTemp is available AND that the temperature is in the second column. I intentionally avoided using awk in my code specifically to not rely on the position of a string. As I commented yesterday, I know what the problem is for some who doesn't have temperature but I am pretty busy in these days and will probably release an update in weekend.

For those of you who don't want to wait, use "rfind" instead of "find" when you are searching for the end period ("."). - Jan 07 2011
OK, very helpful informations. I see the problem and I'll fix it in the coming days. Stay tuned :D - Jan 06 2011
Please download the file, open a console, cd into the directory where you saved the file and try to install it from there with: plasmapkg -i ./Simple-NVidia-Info.asmoid

Usually console messages are more detailed and I may be able to fix/modify it to solve your problem, too.

BTW I am running on Mandriva 2010.2 64bits and also on KDE 4.5.4. - Jan 05 2011
Great, I know what the problem is now. Expect an update soon! - Jan 04 2011
Hmm ... interesting, what does this show for you? I think this problem is solvable, but since it does not happen for me, I need a little bit more information:
nvidia-settings -q all | grep -i videoram - Jan 04 2011
Do you get any errors when you install it from a console like this: plasmapkg -i ./Simple-NVidia-Info.asmoid or if you run it like this: plasmoidviewer Simple-NVidia-Info ?? - Jan 04 2011
Hmm ... sorry ... on my system (Mandriva 2010.2 64 bits, KDE 4.5.<something>) the text is smaller than the plasmoid initial size, but I still resized it to fit the width of the other plasmoids I have on the desktop, and it keeps it's size. Strange it does not for you.

Maybe someone else has an idea or somebody can direct me to a tutorial/document on how to fix this. - Jan 01 2011
I am happy it works :)

As I said in the description of the plasmoid, I do not have the time to make a settings window and options for this.

If there is someone keen to provide a patch I am happy to include it and release it, but I will not invest time into this. - Dec 31 2010
Did you install version 1.1? I modified it to read GPUCoreTemp as in the above patch plus added some fallback logic. Since I have both "GPUCoreTemp" and "thermalsensor" on my system I tested with both scenarios and it works.

Just to be sure, uninstall the plasmoid first with this command from a console:
plasmapkg -r Simple-NVidia-Info

Then simply install it again. - Dec 31 2010
Do you have the Python KDE / QT packages installed? Other Python based plasmoids are working for you? - Dec 28 2010
Please someone give me the output of these 2 comments so I can troubleshoot the no temperature problem:
nvidia-settings -q all | grep -i temp
nvidia-settings -q all | grep -i therm

I am getting the temperature from the "thermalsesnor" property of nvidia-settings, maybe some version or card doesn't have this but it has "GPUTemp" property or something similar.

Since I have only one and my own video card to test on, all of you don't having the temperature please answer my request, otherwise I can't help you! - Dec 28 2010
Hmm... can you give me the output of these 2 commands?
nvidia-settings -q all | grep -i temp
nvidia-settings -q all | grep -i therm
- Dec 27 2010
Simple NVidia Info v2

Plasma 4 Widgets 7 comments

Score 72.2%
Dec 28 2011
The °C is not a constant problem. For example, on my computer I can see °C for hours, then suddenly it changes to ?C than after some time it comes back to °C. Unfortunately I can not MAKE IT look ?C. Whenever I start the plasmoid in plasmoidviewer I see °C correctly and I found no way to reproduce the ?C behavior except putting it on my desktop and waiting for it to magically change. - Dec 28 2011
Updated, made text smaller, I wanted to add a configuration dialog, but I don't have the time right now.

I do not know, yet, why the degree symbol changes into '?'. It is a knows issue, but I have no idea why it happens. - Dec 28 2011
Hmm ... the problem is, that the text is too long and does not fit in one line. I will make the font smaller a little bit and post an update soon.

Thank you for the feedback! - Dec 18 2011
ShortLog

Plasma 4 Widgets 12 comments

Score 77.7%
Jan 31 2011
I installed it on KDE 4.5.5 on Mandriva ... install went OK. I can't find plasmoid anywhere.

Tried to install from net, reinstall, install from file with plasmapkg.

It also doesn't show up in plasmoidviewer --list, however if I want to install it again with plasmapkg it says it's already installed.

Restarting X & KDE doesn't help either. - Jun 10 2011
Playing With Xfce (aka PWX)

GTK2 Themes 2 comments

Score 50.0%
Mar 04 2010
Koszonom - Mar 04 2010
Yasp-Scripted (Systemmonitor) v1.0.8a

Plasma 4 Widgets 301 comments

Score 82.1%
Feb 25 2011
I talked with the packager. It is irrelevant where you will keep/put your scripts since he already made the spec-file for the RPM to package it in ~/.yasp.script (or something like that).

So, don't worry, we are good.

However, as a next evolution of your script, you should make an interface for selecting sensors and auto-magically generate the script. Something like "gkrellm" can do.

This is an extremely good plasmoid for technical people (like me), but most of the users are "afraid" of, or just too lazy to modify files and build their own scripts. - Jan 25 2010
On Mandriva RPM packages contain precompiled binaries.

So, your instructions should be enough. Sorry for the file-selector request, it wasn't mentioned in your changelog, and I didn't tried the last version, yet.

Putting the script files in /etc/<something> I don't thing is a good idea because users may not have access to /etc/ ... may /usr/share/<somethnig> ... I will talk with the guy responsible for compiling it for MRB and I'll be back to you. - Jan 24 2010
The MRB project (http://mrb.mandrivausers.ro) packaged your plasmoid for mandriva as RPM, we very much like your plasmoid.

However, this packaging opened a situation which led me to write you this feature request.

As you offer different scripts for YaSP (and I will send you more in the near future) you should reorganize them so that packaging can be done easily.

What I am thinking of is offer a file dialog for the user to select a specific script file. Also, you should offer a very basic default script, so that when the user first starts the plasmoid he/she can see something other than an empty box. The best would be just a simple memory+cpu monitor which is available on all systems.

The other thing for this to be more organized is that you should make a folder ~/.yasp.scripts and put all the scrips in there. In setting offer a file selection which defaults to that folder and users cans see all the other script files.

If you do this, packaging your program for different distributions will be much easier, and unexperienced users, who don't want to write their own scripts, will find out easily about the scripts and they will be able to test them without modifying/copying files.

Thanks. And very good work! - Jan 24 2010
No, we don't have any problem with Mandriva or KDE. Mandriva uses a technology to start your DE (ex. KDE) as soon as possible. So, in many cases, the graphical interface comes up before the network or other services. Those services come up in few seconds after KDE is already loaded. This usually happens on newer computers, which are fast enough to start the graphics faster than the rest of the services.

So, YaSP is loaded before network is up, and it waits indefinitely on eth0. The sensor for Eth0Down is:
sensor name="Eth0Down" type="engine" cmd="systemmonitor:network/interfaces/eth0/receiver/data:value"
The sensor becomes available as soon as there is a network connection, but YaSP can't sense it. If the sensor would not come available, YaSP would fail on a restart of the plasmoid, too. But it doesn't, on second run, it gets the sensor correctly. - Jan 24 2010
That's why you can display the exact UP/Down values (see second screenshot).

I will try auto-scale as soon as I get home, I was thinking about this, too. - Jan 13 2010
OK, I understand, but than, if I right-click on it and select Reparse, you should drop all waitings and reparse the script.

I have nothing against you waiting infinitely, but let me reparse my script so I don't have to stop/start/reconfigure/rearrange the plasmoid or restart KDE if a sensor fails. - Jan 13 2010
I found a small and annoying bug. If, for some reason, a device I monitor with YaSP is not available at the moment of loading the plasmoid / parsing the script file, it just hangs there. It never stops.

If I right-click on it and select "Repars", than it starts parsing but fails at the first element and waits again indefinitely.

Restarting the plasmoid makes it work again.

For a frequently encountered example, I use Mandriva 2010 and KDE 4.3.4. Mandriva starts the graphical DE as soon as possible, so many times the network adapter is not yet connected when the KDE (and YaSP) is loading. The result is the above mentioned problem.

I would suggest to set a timeout in your script. If the parsing fails, just show an error and try again in a few seconds, so the plasmoid is not blocked waiting for something. - Jan 08 2010
Thanks for the quick reply.

As I said, I don't know how you made the icon thing. I did not check your code. If it's a QPixmap, loaded only once, that's perfect. I just thought to suggest something like this by not knowing the exact procedure you implemented. Yes, I could check the code, but I was too lasy ;)

Why icons for text? Why not, if it's easy to implement.

Thanks for the text type clarification. I always have a hard time figuring out QT documentation ;) - Dec 29 2009
First of all, good work. I tried YaSP Scripted when it was v0.3 and I did not liked it back then. Now it's much much better and uses less resourses.

I've sent you a mail with my script and screenshot.

And now, what I would like to be implemented in the future:
- icons for meters, charts and text
- I don't know how it is done, but icons should be cached in RAM, so the file is not re-read every time the "value" containing an icon refreshes
- it still uses pretty much resources if charts are updated faster than 4 secs.
- possibility to add value to Title, so I could add, for example, distribution name in the title.
- icons for titles
- I couldn't figure out how to make a font BOLD, it does not accept QFont parameters for bold. Font definition should be like QFont is: QFont ( const QString & family, int pointSize = -1, int weight = -1, bool italic = false )
- you could add "height" parameter for "Meters", too - Dec 29 2009
First of all, good work. I tried YaSP Scripted when it was v0.3 and I did not liked it back then. Now it's much much better and uses less resourses.

I've sent you a mail with my script and screenshot.

And now, what I would like to be implemented in the future:
- icons for meters, charts and text
- I don't know how it is done, but icons should be cached in RAM, so the file is not re-read every time the "value" containing an icon refreshes
- it still uses pretty much resources if charts are updated faster than 4 secs.
- possibility to add value to Title, so I could add, for example, distribution name in the title.
- icons for titles
- I couldn't figure out how to make a font BOLD, it does not accept QFont parameters for bold. Font definition should be like QFont is: QFont ( const QString & family, int pointSize = -1, int weight = -1, bool italic = false )
- you could add "height" parameter for "Meters", too - Dec 29 2009
Bespin

Be-Shell/Bespin 1662 comments

Score 82.7%
Apr 25 2013
I forgot to mention ... ONLY FOR KDE 4.3.4 - Dec 30 2009
Latest Bespin SVN with Translucency enabled is available for Mandriva 2009.1 and 2010.0 as a RPM package on the MRB repository (http://mrb.mandrivausers.ro)

For the moment only 64 bits packages are available. i686 packages may come later.

Thanks to symbianflo. - Dec 30 2009
Glassified

Plasma Themes 262 comments

Score 64.2%
Feb 14 2010
If Lancelot Part is put on desktop, the text on it is black. If you have a darker background the tex is impossible to read.

Coud you make the text white for Lancelot Part? Thanks. - Jun 08 2009
Oxyzone

Plasma Themes 17 comments

Score 72.2%
Jul 26 2009
mee stupid ... it's already done ... sorry for the confusion - Jun 08 2009
+1 for Lancelot theme ;) - Jun 08 2009
Daisy

Plasma 4 Widgets 574 comments

Score 81.9%
Jul 14 2012
Your rpm doesn't work. I'm getting Daisy in the list, but when I want to add it, it says it is impossible since there is no such plasmoid. And yes, I restarted plasma. - May 30 2009
Mini Player

Plasma 4 Widgets 142 comments

by Emdek
Score 82.0%
Jul 01 2012
- when it is resized, the icons doesn't keep centered, especially when it is made smaller. It seems like you have a minimum space from the top of the plasmoid.
- for the same reason, it is unusable on a thin Panel
- volume control doesn't pop up near the volume button. Regardless where my plasmoids placed, volume control pops up somewhere in the middle of the screen.
- if you put the plasmoid on the desktop, than accidentally drag it over the Panel (as I did) it enters the Panel. This in fact is not bad, but, if you than drag it back to the desktop, you end up with a broken plasmoid. I had 2 lines of icons on it and none were working.

These are of course some little glitches, maybe they are also easy to fix... - May 12 2009
This is FANTASTIC! It works perfectly with the radio station I listen to and it uses very little CPU too.

I love it now, on my laptop it integrates seemlessly into the desktop and it is not a resource hug ... well at least after the first 5 minutes.

I am curious if it remembers what I was listening to when I restart KDE (or the computer). I will not restart just for this, so I'll see tomorrow.

Great job, you have e new fan. - May 12 2009
Great, can't wait for it :D - May 10 2009
Are there any plans to implement playback of online radio? I would like to use this to listen some online radio. Right now it can't open http://some-radio-server/playlist.m3u nor the direct stream link.

This would be a great addon to this plasmoid and would make it more usefull.

Thanks. - May 08 2009
Tragedy

Plasma Themes 89 comments

Score 80.0%
Mar 13 2010
Can you please make a modification of Tragedy with the translucent background and publish it? I proposed this idea a long time ago, but I was waiting for version 1.0 to do it. As you already done it, it would be nice to have this wariant as a separate theme for download. Also, please apply the translucent background for the Panel, Taskbar, Tray, Shutdown Dialog.

If you don't have time to do it, just upload your current version somewhere and I'll modify the remaining parts.

Thanks. - May 03 2009
I confirm, both analog clock and network monitor colors fixed and working properly.

Thanks - Apr 28 2009
Just installed 0.9, same issue with the clock. I can see the same effect described above when resizing, and it also looks like the background doesn't resize correctly.
http://imagebin.ca/view/VaV7ukrG.html

An one more little problem, with System Monitor plasmoid => Network Monitor, the text is unreadable. This brownish text on the very dark grey background is indistinguishable.
http://imagebin.ca/view/n9pYlt0.html

And I like the new addons ;) Battery meter looks really good, shutdown dialog is OK too (maybe to put an image on it, like the "moon" in Oxygen). - Apr 23 2009
The update didn't helped, but don't bother solving it. I can just resize the clock.svg and solv it for myself. Anyway I'll switch to KDE4.2.2 in about 2 weeks (as soon as Mandriva 2009.1 is out) so this problem may solve itself in the near future.
- Apr 15 2009
I tried what you suggested and read that page ... I tried different themes and I even cleared KDE's cache for themes ... No change.

However, I found a temporary solution. I tried to modify the clock.svgz and it seems like the deformation depends on the size of the image. I took your image, selected all elements and resized them to have an approximate 250 pixel in width. Than scaled the indicators to the same size of the background. Now, it looks good.
Than I tried to scale the image itself, I mean the virtual page you are drawing on, to be the same size, or just a little bit bigger than the clock. The problem came back instantly. So, this is a very strange behaviour and it depends on the size of the image raported to the size of the page. - Apr 15 2009
I like very much the new Analog Clock ... but on my desktop it has a little problem. The indicators are longer than the background. See this screenshot: http://imagebin.ca/view/ahmE_lj.html

I've tried to:
- update theme
- uninstall/reinstall
- several logout/login between the above operations

Also, my Lancelot has white background for search, not black as in your screenshot ...

As I suspect the problem is on my part, I would really like some sugestions how to fix this.

I'm using Mandriva 2009 with KDE 4.2.1 and QT4.5 with all dependencies and developtment packages installed.

PS: The OLD Analog Clock did not have this problem. - Apr 14 2009
translatoid

Plasma 4 Widgets 284 comments

by dridk
Score 68.0%
Nov 30 2010
I installed both Festival and espeak. Whatever I chose in the settings it goes back to Festival immediatly. I observed this when I wanted to make a custom command, so I can set up some parameters for espeak ... but it is not working. I set whatever I want, I click ok, window is closed and setting is reverted to Festival.
Thanks. - Apr 23 2009
Never mind ... I had to configure something in Festival. It si working now. - Apr 23 2009
It's working perfectly and it remembers the previously selected languages. Thanks for this update.

BTW, I tried to enable voice. I installed Festival, the plasmoid says it's there, but I hear nothing when I click on the little blue icon in you plasmoid ... do I have to set up somethnig special with Festival? - Apr 23 2009
Mini Player

Plasma 4 Widgets
by Emdek

Score 82.0%
May 12 2009
Tragedy

Plasma Themes
by jmtodaro

Score 80.0%
May 03 2009
STasks

Plasma 4 Widgets
by mbaszczewski

Score 64.5%
Feb 23 2009
Score 84.7%
Feb 19 2009
Oxyglass

Plasma Themes
by Numerus

Score 77.8%
Jan 23 2009
Dropbox ServiceMenu

Dolphin Service Menus
by hash87

Score 85.0%
9   May 16 2012