Image 01
profile-image

hoganrobert

Robert Hogan dublin, Ireland
Network
Security
Various KDE 1.-4. Improvements
TorK

Network 85 comments

Score 50.0%
Feb 05 2009
Fixed in CVS I think. Thanks a million for taking the time to explain this with the screenshots - really helped me out.

http://tork.sourceforge.net/wiki/index.php/Install_TorK_from_CVS - Sep 29 2007
you should probably re-run the first run wizard. 0.19 enforces cookie authentication by default for local instances and recommends password-authentication for remote. i'm pretty sure it will work if you re-run the first run wizard. let me know by email if it doesn't. - Sep 23 2007
have you tried with ./configure --prefix=/usr ?

try doing a "find . -iname 'tork'" in /usr when you've compiled and installed.

also watch the output from the installation to see where it installs it. - May 26 2007
you need to install all packages with x and devel/lib in the title - May 03 2007
you need to install the lib-konq package. may not have the name exactly right but it will have lib and konq (and/or possibly devel) in the title. - Mar 08 2007
should be there somewhere. though you've probably found it by now! - Feb 21 2007
this is because tor does not officially support p2p networks. their use creates high latency. - Nov 26 2006
if there's anyone out there who would like to create one I will link to it on TorK's homepage. - Oct 31 2006
it's certainly meant to work! can you describe the problem you're experiencing in more detail? - Oct 20 2006
do ./configure --with-kde-libraries=/location/of/your/libs - Jul 13 2006
you can turn it off completely by using the rightmost button on the button-panel. could you take a screenshot of the osd in action on your screen to give me an idea of how it looks for you? (hoganrobert@users.sf.net) - Jul 07 2006
That's a good idea. I've added it in CVS and it seems to work OK. Should be available in anonymous cvs within a few hours if you'd like to try it:

http://tork.sourceforge.net/wiki/index.php/Install_TorK_from_CVS - Jun 22 2006
they're grayed out because 'use default settings' is set in the 'quick configure' tab. to free up the other tabs for use select 'let me configure tor myself'... - Jun 20 2006
you probably have an older version of kde - tork needs kde 3.5.3 to compile. and yes, there should be a warning in the configure script. i'll fix this, thanks for pointing it out. - Jun 20 2006
yes i can replicate this problem using that version of tor. it disappears when i click tools->download tor and download and compile the latest experimental version using the wizard.

could you try that and let me know how you get on? - Jun 20 2006
i'm an idiot. The tarball was screwed. Please try the new version which (hopefully) will work for you.. - May 29 2006
weird. what does 'locate uic' give you? it may be you don't have the qt development tools installed, e.g. your distro's qt-devel package. are you compiling as root? that could be the problem... - May 19 2006
should be doable. will add it to the list. - May 19 2006
could you post the output here or to the mailing list mentioned in the description? thanks. - May 19 2006
Primary

Full Icon Themes 22 comments

Score 67.1%
Jun 18 2018
what a lovely icon set. i've been using it for a few days and i'm not going back - well done on a great job. - Aug 14 2006
KlamAV

Security 150 comments

Score 50.0%
Feb 17 2009
out of scope i'm afraid - Feb 13 2006
mmm... got chopped. If you're impatient for the bugfix release just go into directorylist.cpp and replace each occurence of:

if ( KDE::version() == 3 && KDE::versionMajor() < 4 )

with

if ( KDE::versionMajor() == 3 && KDE::versionMinor() < 4 ) - Jan 19 2006
I forgot to reorganize this package. Thanks for pointing this out. - Jan 19 2006
Thanks for reporting this bug.

This patch will fix it:

--- directorylist.cpp 2006-01-19 18:55:28.000000000 +0000
+++ directorylist.cppold 2006-01-19 18:55:14.000000000 +0000
@@ -235,8 +235,7 @@
{
m_lister.setDirOnlyMode( true );
connect( &m_lister, SIGNAL(newItems( const KFileItemList& )), SLOT(newItems( const KFileItemList& )) );
-
- if ( KDE::versionMajor() == 3 && KDE::versionMinor() < 4 )
+ if ( KDE::version() == 3 && KDE::versionMajor() < 4 )
{
m_url = "devices:/";
}
@@ -270,7 +269,7 @@
streamout - Jan 19 2006
if klamav is open when you log out it will reappear when you log in again. this means there is no need to configure it to start when you log in - it will do this anyway.

also, check your autostart folder ($KDEDIR/share/autostart) and see if there are any files in there with klaamv in the name.

(if you schedule a scan for when you log into kde klamav will put a file in here - it should delete it if you delete the scheduled scan though. let me know what you find in the autostart folder as that is the most likely source of your woes...) - Dec 04 2005
try the faq and instructions at www.dazuko.org. installing dazuko manually might cure your woes... - Oct 31 2005
there's no need to recompile your kernel afaik. - Oct 23 2005
have you libjpeg-devel installed? this is the first thing google threw up at me.... - Oct 07 2005
looks like the compiler output you pasted in got truncated - i can't find any error here (except for the ugly warnings about qucom_p.h which is not a klamav file, don't know what the problem is there). would you like to mail me the full output please? - Oct 02 2005
* insmod: error inserting '/lib/modules/2.6.13-9-default/dazuko.ko': -1 Unknown symbol in module
* mknod: missing operand after `0'

does 'modprobe dazuko' work for you? - Oct 02 2005
is clamav-0.87 untarred in your $HOME/.klamav directory?

what happens you run the following from the command line?

$HOME/.klamav/bin/arkollon $HOME/.klamav/clamav-0.87 - Sep 29 2005
i think this is happening because klamav cannot find the installer program 'arkollon' on your system. it should have been installed to $HOME/.klamav/bin/ during the installation process. is it there? if not, how did you install klamav? - Sep 26 2005
does the 'source' tarball (http://sourceforge.net/project/showfiles.php?group_id=102171&package_id=160304&release_id=358418) address your concerns?

building a klamav package should be much the same as before, the trick is to package arkollon with it somehow so that updates to clamav/klamav can be downloaded and compiled. (it has to be the slightly modified arkollon i include in the source package :(

please let me know if it possible to build a package with the source components.. and thanks for your feedback - there is no reason why the feature can't be removed if it is just too godawful, but it would be nice if the upgrade process could be made as easy as possible with minimum of infrastructure... - Sep 26 2005
what version of klamav are you using? - Sep 25 2005
a fix for this will be released in 0.30.2 - thanks for reporting. - Sep 21 2005
unfortunately i can't recreate this (slackware-current). I can see where the problem is happening for you but unfortunately troubleshooting it will be hit and miss until i can get a suse installation up and running.

could you do me a favour in the meantime? download the source package from the sourceforge website and replace the first four lines in the startProgressDialog function in freshklam.cpp with:

if ( progressDialog )
delete progressDialog;

progressDialog = new KProgressDialog( this, "progress_dialog", QString::null, text, false );

and see if it helps... - Sep 19 2005
can you tell me when this crash happens? how do you recreate it? - Sep 16 2005
it looks like some pruning of file headers has caused compile problems with some people's distributions. In your case, adding

#include kstdguiitem.h

to the top of schedule.cpp should fix the problem.

i'm releasing klamav-0.30.1 to fix this problem and a few others so please download the new version to fix it when it becomes available. - Sep 13 2005
can you be specific about how it didn't work for you? if possible, please post your observations to klamav-users@lists.sourceforge.net.

the installer is experimental and I would dearly like to get it to work for everyone (so clamav and klamav can be updgraded automagically), so your feedback will be listened to... - Sep 13 2005
not sure why this is happening for you and not me/others. probably a red hat 9 thing.

adding:

#include unistd.h
#include sys/types.h

to the top of cthost.cpp is sure to fix it though.

be sure to open and close unistd.h and sys/types.h with triangular brackets (the notice board html parser swallos them) - Sep 10 2005
you should try the process manually. the installation of dazuko attempted during the installation process is as follows:

cp dazuko.*o /lib/modules/`uname -r`
insmod /lib/modules/`uname -r`/dazuko.*o

rm -f /dev/dazuko;

mknod -m 600 /dev/dazuko c `grep dazuko /proc/devices | sed "s/ .*//"` 0;

chown $USER:clamav /dev/dazuko

hope this helps.

P.S. To manually install KlamAV you should proceed with installation until you are at the first step of the arkollon wizard. Then you should navigate to your /tmp directory and enter the directory beginning with selfgz. You will find the sources there.

Apologies for the inconvenience caused, but this new installation method is an experiment and is the best way I could find of providing a platform independent way of keeping both KlamAV and ClamAV easy to update and install. - Sep 10 2005
you should check that you have dazuko installed. autoscan will attempt to load the module with the command 'modprobe dazuko'. see if this command works for you from the command line. - Apr 18 2005
I recommend downloading the latest release of dazuko at www.dazuko.org and giving it a spin.... - Mar 21 2005
mmm. have you tried performing the commands manually (as root)?

cp dazuko.o /lib/modules/`uname -r`/

'modprobe dazuko' or 'insmod /lib/modules/`uname -r`/dazuko.o'

mknod -m 600 /dev/dazuko c `grep dazuko /proc/devices | sed "s/ .*//"` 0 - Mar 17 2005
you can put 'modprobe dazuko' or something similar in your initialization script. I will look into putting this into the installation procedure... - Feb 06 2005
this has been fixed in 0.09.4 - Jan 24 2005
are you using the 'quarantine' and 'warn' checkboxes? - Nov 07 2004
i'll fix this in the next release.. thanks for pointing it out. - Nov 07 2004
The main reason its bundled is that Klamav requires a patch to the clamuko part of clamd. Also, clamav tends to change an awful lot, so bundling at least ensures you will have something that works out of the box... - May 08 2004
Not sure what you mean here. It's a front-end for scanning files on a *nix system with ClamAV. Does that answer your question? - May 03 2004