plasmaCpuFreqUtility

Plasma 4 Widgets

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

5
Score 78.4%
Description:

Simple plasmoid for change frequencies of processors, enabling or disabling them.
Plasmoid needs polkit-1, d-bus.
May need to configure SELinux.

Dependencies:
PyQt4
PyKDE4

Installation:
cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` .
make
su -c 'make install'
(building correct for Fedora)
Last changelog:

7 years ago

v.1.4.1 :
fixed cpu info store to dict;

v.1.5 (final):
some fixes;

v.1.6 :
added 'First For All' mode setting;

Kaktuss

5 years ago

Dear F1ash!
Thank You very much indeed!
I really need a workable non-console utility to change cpu frequency for KDE 4 OpenSuse 13.1. And I was searching it for a long time. I tried applets for cpufrequtils that do not work in my system or adjust only one core like CpuFreqTray-0.9. But Your plasmoid is not only workable for all cores. Your plasmaCpuFreqUtility is the best from all cpu frequency regulators that I can find. It even has a very useful autorun option. The best functional and the best design of cpu regulators that I have ever seen. Now my notebook can be not so hot.
Thank You very much indeed!

Report

dmnmsc

6 years ago

Good plasmoid! Just what I need! But... could be possible to change all CPU governors wth only one move? I mean set all cpu governors to conservative (for exameple) at same time, not going one by one.

Report

dmnmsc

6 years ago

OK, I'm sorry. I see this option now. Thanks again!

Report

dmnmsc

6 years ago

Good app! Just what I need! But... could be possible to change all CPU governors wth only one move? I mean set all cpu governors to conservative (for exameple) at same time, not going one by one.

Report

wingnux

6 years ago

wingnux@wingnux-desktop:~/Downloads/kde-plasma-cpufrequtility-1.6$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` .
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/wingnux/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:7 (find_package)


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.8)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

Report

C

F1ash

6 years ago

I'm fine. Maybe you forgot to install the kdelibs5-dev package?

Report

wingnux

6 years ago

Thanks, that solved the compiling problem but now when I add the plamoid to my kde panel I get a warning that says "KAuth returned an error code: 3" twice and when I click on the plasmoid icon it shows a red "ERROR" message.

Report

C

F1ash

6 years ago

This occurs when an error reading\writing (as I understand, your comp have two core). It is likely that the rules for polkit not been applied. Relogin user.

Report

tittiatcoke

7 years ago

I like this plasmoid very much, but what I found is that once I disable a CPU, there is no way to get it enabled again. The line with the disabled CPU is not showing anymore.

Report

C

F1ash

7 years ago

I can not reproduce this bug. Try to find errors in the file ~/.xsession-errors .

Report

Deathmachine

7 years ago

Hi
Can you please add a option to change cpu-freq policy for all CPUs?

Report

C

F1ash

7 years ago

Try new version ;)

Report

Deathmachine

7 years ago

Thanks

Report

C

F1ash

7 years ago

I'll do when I get free time

Report

warrob

7 years ago

Hi,

I installed the plasmoid from the kde-files service on my debian-sid machine. It says twice:
KAuth returned an error code: 3
and then appears the square orange button that says "error" when pressed.

I haven't compiled nothing, just installed from plasma service.

Report

C

F1ash

7 years ago

In Fedora the compile requires is gcc-c++ & kdelibs-devel packages.
In Ubuntu : kdelibs5-dev ( https://github.com/F1ash/plasmaCpuFreqUtility/issues/1 ).
In Debian : I don`t know. It`s may be kdelibs5-dev or similar.

Report

warrob

7 years ago

I don't understand why does it need compiling, being python.

Besides, I think it's wrong to let install a plasmoid without making the user aware of the missing packages or automatically installing them.
Also, installing kdelibs-dev requires tens dependencies of dev-packages. All that stuff for a plasmoid? Isn't there any better way? Why the other plasmoids don't need compiling and all that dependecies?

thanks

Report

C

F1ash

7 years ago

Part of the code written in C++ (no other way). It is therefore necessary compiling, and this requires a similar package kdelibs-devel.
You can write a spec for Debian, and I will add it.

Report

stathisq

7 years ago

Hi guys,
I'm still having this problem:

This object could not be created for the following reason:
Can't open the package kde-plasma-cpufrequtility requested by the object CPUFreq Utility.

I have read the answers above,but I cannot find out how to make it work...I'm using Arch Linux...Has anyone made it to work...
Btw thank you about this really useful plasmoid...

//sorry about my poot English...

Report

C

F1ash

7 years ago

Unfortunately, I can not test on Arch. Then for Arch needs to rewrite some parts of the plasmoid.

Report

gzu

7 years ago

Hi
I'm also getting a script initialisation error in Fedora 15, I think I have all the dependencies satisfied see error below

plasmoidviewer(28721)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
plasmoidviewer(28721)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)

Traceback (most recent call last):
File "/usr/share/kde4/apps/plasma_scriptengine_python/pyappletscript.py", line 75, in init
self.pyapplet.init()
File "/usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/contents/code/main.py", line 138, in init
self.Control = ControlWidget(self.ProcData, self, os.path.dirname(self.iconPath))
File "/usr/share/kde4/apps/plasma/plasmoids/kde-plasma-cpufrequtility/contents/code/main.py", line 262, in __init__
enabled = int(self.ProcData['online'][i].data()[QString('contents')].toString().replace('\n', ''))
KeyError: 1

Thanks for what looks like a great plasmoid.

Report

C

F1ash

7 years ago

Try run 1.4.1.b-version in plasmoidviewer.
If plasmoid don`t work, then you need to add debug output to result.

Report

C

F1ash

7 years ago

Try version (g).

Report

gzu

7 years ago

Hi and Thanks,

That looks like it is working for me now, just the icon size but I can live with that. Does the icon have a black border that might me causing it to look smaller?

Thanks again,

gzu

Report

C

F1ash

7 years ago

Ok. Icons do not have a border.
When I find the icons with larger size, then upload the final version.

Report

7 years ago

v.1.4.1 :
fixed cpu info store to dict;

v.1.5 (final):
some fixes;

v.1.6 :
added 'First For All' mode setting;

12345678910
114
product-maker mirkogennari Dec 02 2016 9 excellent
product-maker Kaktuss May 02 2014 9 excellent
product-maker grusta May 17 2013 9 excellent
product-maker schleby Mar 12 2012 9 excellent
product-maker nowsy Mar 12 2012 9 excellent
product-maker Deathmachine Mar 07 2012 9 excellent
product-maker warrob Feb 21 2012 9 excellent
product-maker pars1938 Dec 21 2011 9 excellent
product-maker freemanoid Nov 09 2011 9 excellent
product-maker stathisq Oct 10 2011 3 bad
product-maker Hanau2010 Sep 18 2011 9 excellent
product-maker tritemius Sep 02 2011 9 excellent
product-maker TommyCZ Sep 01 2011 9 excellent
product-maker robyshot Aug 29 2011 9 excellent
product-maker unikum111 Aug 29 2011 9 excellent
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
1.6
updated Mar 12 2012
added Aug 29 2011
downloads today
0
page views today 9